Tranny problems

Help Support CattleToday:

DustyH

Well-known member
Joined
Oct 28, 2006
Messages
74
Reaction score
0
Location
Louisiana
I have an 05 duramax with the allison, all is stock. I hooked to an empty gooseneck today and put it in 4 wheel drive to get up a muddy drive way. When I got to the pavement I forgot to put it in 2 wheel drive. After about a 25 mile drive I stopped at a stop sign and when I started to go the tranny stalled for a second then slammed forward. After that it wouldn't shift out of 1st. I took it real slow and got home. When I unhooked the trailer I killed the truck and let it sit for a few minutes. I then cranked it up and moved forward still won't shift. When I put it in reverse it jerks real hard going into gear. Any ideas what might be going on?

--------------------------------------------------------------------------------
 

jedstivers

Well-known member
Joined
Oct 22, 2008
Messages
5,787
Reaction score
1
Location
Marianna Arkansas (East Central)
dieselbeef":1h5jvrp0 said:
unhook the batts for 5 min and see if it helps to reset the ecm
If that doesn't work check with the dealer about a flush. I know the Allison is different than the one in the gas burners but this might apply, varnish builds up on the valves and causes shifting problems. A can of something is poured in the transmission then you drive for a few days then the transmission is hooked to a machine that pumps out the old oil and pumps in the new.
 

lavacarancher

Well-known member
Joined
Jan 6, 2009
Messages
1,960
Reaction score
0
Location
Lavaca county, Texas
Never been into one of the Allisons but if I were a bettin' feller I'd be puttin' money on the innards of the transfer case. You've probably welded some gears together. If it is the transfer box you might be glad $$$$ wise.
 
Top