2001 F250 7.3l problems

Help Support CattleToday:

lifeofleisure

Well-known member
Joined
Jan 14, 2009
Messages
49
Reaction score
1
Location
Craig County, Virginia
I have a 2001 F250 4x4 diesel truck with standard transmission I bought new that currently has less than 60k on it. Last November It started acting up running like it had water in fuel. I had the crank position sensor changed under warenty at that time. I also had to replace the fuel water separator valve on it as it had started leaking.

Now I have intermitentant symptoms again. While running at speed it will start running like it has water in fuel, or hust missing and looses all power. I can turn off and restart and it will run fine, maybe for a week maybe for 30 seconds. It does not seem to matter if under a heavy load or light one.

I had let it set for about a month since I have an old 89 toyota that I use at times as well. It ran fine yesterday but last time I ran it it quit about every 5 miles.

Any ideas?
 

High Cotton

Well-known member
Joined
Nov 9, 2010
Messages
363
Reaction score
0
Location
West Tennessee
Injector harness? Those trucks have issues with those from time to time. You already changed the most common failure. also if it hasn't had a new fuel filter since it started acting up change it and see what happens.
 

dun

Well-known member
Joined
Dec 28, 2003
Messages
47,334
Reaction score
11
Location
MO Ozarks
That's about when the high pressure oil pump that runs the injectors started to screw up on my old 2001
 
A

Anonymous

Injector harness or hpop. There was also a lot of bad cps modules put out when they all started going bad.it honestly sounds more like the harness or cps since its so intermittent. Get a mechanic to put a good scanner on it and read the cps and the hpop output
 
Top